Написать программу по информатике (можно на pascal или на c++)!
количество минимумов
найдите количество минимальных элементов в последовательности.
входные данные
вводится натуральное число n, а затем n чисел.
выходные данные
выведите количество минимальных элементов.
например :
мы вводим :
3
21
11
4
на выходе получаем : 1
#include <iostream>
using namespace std;
void main(){
int N, a, min, cmin;
cin >> N;
cin >> min;
cmin = 1;
for(int i=1; i<N;i++){
cin >> a;
if(min==a)
cmin++;
if(min>a){
min = a;
cmin = 1;
}
}
cout << cmin;
}
PascalABC.NET (Обязательно .NET, используется библиотека классов .NET)
begin
var list: List<integer> := new List<integer>;
var N := ReadInteger();
for var i := 1 to N do
begin
list.Add(ReadInteger());
end;
list.Where(x -> x = list.Min()).Count.Println();
end.
Объяснение: