В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
алгебра108
алгебра108
12.06.2020 09:22 •  Информатика

Написать программу по информатике! дана непустая последовательность целых чисел, оканчивающаяся отрицательным числом. верно ли, что все элементы последовательности равны между собой?

Показать ответ
Ответ:
Яна00311
Яна00311
05.10.2020 10:56
// PascalABC.NET 3.2, сборка 1381 от 04.02.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var n:=ReadInteger('Длина последовательности: ');
  var a:=(SeqRandom(n-1,0,1)+(-1)).ToArray; // последовательность 0 и 1
  a.Println;
  if a.Where(x->x>=0).Distinct.Count>1 then
    Writeln('Есть отличающиеся элементы')
  else Writeln('Все элементы равны')
end.

Примеры
Длина последовательности:  4
1 1 1 -1
Все элементы равны

Длина последовательности:  5
0 1 1 0 -1
Есть отличающиеся элементы
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота