В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
casha0032
casha0032
12.03.2022 10:33 •  Информатика

Написать программу перевода числа из двоичной системы в десятичную с использованием функции возведения в степень. я написала, но у меня где-то ошибка. b: =0; m: =length(max)-1; j: =m; for i: =1 to m do begin val(max[i],p,code); while j> =0 do p: =p*step(2,j); b: =b+p; j: =j-1; writeln(b); end; поясняю, что тут и как. эта мини-, входящая в решение одной масштабной . дана строка max, в которой записано двоичное число. функция step(x,y: integer): integer возводит число x в степень y. найти и исправить ошибку, только, , не надо писать совершенно другой решения. заранее ))

Показать ответ
Ответ:
поля875
поля875
01.10.2020 23:04
Begin
 
  max := '1010';
  b := 0;
  m := length(max);
  j := m - 1;
 
  for i := 1 to m do
 
  begin
   
    val(max[i], p, code);
   
    {while j >= 0 do}
   
    p := p * step(2, j);
   
    b := b + p;
    j := j - 1;
   
    writeln(b);
   
  end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота