В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
ananas6947
ananas6947
03.06.2022 17:26 •  Информатика

Написать программу Паскаль! 1.Вывести на экран и подсчитать количество натуральных чисел типа longint,
которые при делении на заданное простое число х, дают в остатке число у.
2.Найти простые числа х и у, которые в произведении дают число z, типа
longint.

Показать ответ
Ответ:
temaganenko
temaganenko
01.02.2022 03:28

Программа:

Pascal:

var

 y: real;

 n, j: longint;

 i, x: integer;

begin

 write('x = ');  readln(x);

 write('y = ');  readln(y);

 j := MAXINT;

 for i := 1 to j do

   if i mod x = y then inc(n);

 writeln(n, ' чисел');

 

end.

Результат:

x =  5

y =  3

429496729 чисел

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота