Написать программу, определяющую, принадлежит ли точка с координатами (x,y) кольцу с центром (x0,y0). r1 и r2 соответственно радиусы внутренней и внешней окружностей, образующих кольцо.
Var x,y,r1,r2:real; begin write('Введите x, y, внутренний радиус, внешний радиус: '); readln(x,y,r1,r2); if (x*x+y*y<=r2*r2) and (x*x+y*y>=r1*r1) then writeln('Да, принадлежит') else writeln('Нет, не принадлежит'); end.
begin
write('Введите x, y, внутренний радиус, внешний радиус: ');
readln(x,y,r1,r2);
if (x*x+y*y<=r2*r2) and (x*x+y*y>=r1*r1) then
writeln('Да, принадлежит')
else writeln('Нет, не принадлежит');
end.