Войти
Регистрация
Спроси ai-bota
В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Показать больше
Показать меньше
pinksuuun
19.02.2020 16:27 •
Информатика
Написать программу определяющую, что точка принадлежит треугольнику на языке с координаты вершин треугольника(-1; 0) (0; 1) (1; 0).
Показать ответ
Ответ:
gorbunovayulia
07.10.2020 15:54
#include <stdio.h>
int main()
{
float x,y;
scanf("%f",&x);
scanf("%f",&y);
if (y>=0 && y<=-x+1 && y<=x+1) printf("YES");
else printf("NO");
return 0;
}
Пример:
-0.2
0.2
YES
0,0
(0 оценок)
Популярные вопросы: Информатика
21Oleg12
02.07.2020 16:10
Екі санның көбейтіндісін есептейтін программа құрыңдар екі таңбалы немесе оданда көп таңбалы екі санның қосындысын есептейтін программа құрыңдар екі санның арифметикалық...
MilenaSmail12
22.03.2022 22:13
. Определите типы данных [2] a)A=’A9’ b)B=456 c) C=123.4 d)D=True...
chernecov1977
22.09.2021 10:20
Help Python. Задача. Дана переменная i=200. Выводите все числа, делящиеся на 3 без остатка, пока переменная i не будет меньше или равна 20. (для решения данной задачи...
olgaborodec82
24.10.2022 06:32
Палочки Имя входного файла: стандартный ввод Имя выходного файла: стандартный вывод Ограничение по времени: 1 секунда Ограничение по памяти: 256 мегабайт Дети в лагере...
Stasuyksuper06
23.03.2023 01:35
решить ! С решением ...
Элиза5511
05.12.2021 05:17
108 бет, 3- тапсырма. Мәтін бойынша сұрақтарға жауап бер. По тексту ответьте на вопросы 1 «Әнші құм» қайда орналасқан? Где находятся «Поющие пески»? 2 Құмды төбенің...
Diana6079
10.04.2021 02:14
Обвести кружком номер правильного ответа: 1. Острым является угол:1) 90 ;2) 89 ;2. Тупым является угол:1) 90 ;2) 89 ;3. Развернутым является угол:1) 90 :2) 89 ;4....
zohvav
21.01.2023 02:04
Прийменник ужито з давальним відмінком у словосполученні: 1.передали через посланця2.всупереч прогнозу3.з ясовувати стосунки з друзями4.прислухатися до думки інших...
сымбатым
31.01.2021 16:34
График функции у kx+b пересекает оси координат в точках а 0 -6 и в 2 0 найдите значение k и b...
2727472927у
01.08.2021 08:25
Укажите две доисторические личности которые были непосредственно связаны с укреплением обороно древнерусского государства ...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
int main()
{
float x,y;
scanf("%f",&x);
scanf("%f",&y);
if (y>=0 && y<=-x+1 && y<=x+1) printf("YES");
else printf("NO");
return 0;
}
Пример:
-0.2
0.2
YES