, написать программу, очень ! Дан одномерный массив вещественных чисел размерностью до 20 элементов, необходимо упорядочить по возрастанию отдельно каждую пятерку элементов, вывести на экран исходный массив и результат работы программы. Заранее
Не ученые мы мужи, но если рассуждать по нашему-по простому то стало быть так: 4 бита маски под 16 государственных подсетей надобно иметь, чтобы 10 перекрыть и еще 5 бит маски надо под 32 губернские подсети, чтобы все 20 поместить и еще 4 бита маски на хозяйственные подсети, плюс 2 бита на районные да 8 на усадебные да 3 на подсети для разных этажей, итого получается аж плюс 28 к 2 царственным. То бишь маска подсетей этажных получается /30 и значит аж 2 компьютера на этаже разместь можно. Ну и теперь считаем так: 2 компьютера x 7 этажей x 60 усадеб x 4 района x 10 хозяйств x 20 губерний x 10 государств = 6720000 хлопчиков будут фильмы на ютубчике глядеть и радоваться.
// PascalABC.NET 3.3, сборка 1549 от 17.10.2017 // Внимание! Если программа не работает, обновите версию!
begin var a:=ReadSeqIntegerWhile(x->x<=100).ToArray; Writeln('Количество четных чисел равно ',a.Where(x->x.IsEven).Count); a.Transform(x->x.IsOdd?x*x:x); a.Println end.
Пример 35 24 38 83 110 Количество четных чисел равно 2 1225 24 38 6889
begin Writeln('S=',ReadSeqIntegerWhile(x->x>=0).Select(x->x mod 10).Sum) end.
Пример 16 24 19 21 45 0 23 -21 S=28
begin var n:=ReadInteger('n='); var St:=new Stack <integer>; while n>0 do begin St.Push(n mod 10); n:=n div 10 end; var a:=St.ToArray; a.Println(','); Writeln('Сумма цифр: ',a.Sum); Writeln('Сумма нечетных цифр: ',a.Where(x->x.IsOdd).Sum); Writeln('Сумма старшего и младшего разрядов: ',a.First+a.Last); end.
Пример n= 53214212 5,3,2,1,4,2,1,2 Сумма цифр: 20 Сумма нечетных цифр: 10 Сумма старшего и младшего разрядов: 7
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ReadSeqIntegerWhile(x->x<=100).ToArray;
Writeln('Количество четных чисел равно ',a.Where(x->x.IsEven).Count);
a.Transform(x->x.IsOdd?x*x:x); a.Println
end.
Пример
35 24 38 83 110
Количество четных чисел равно 2
1225 24 38 6889
begin
Writeln('S=',ReadSeqIntegerWhile(x->x>=0).Select(x->x mod 10).Sum)
end.
Пример
16 24 19 21 45 0 23 -21
S=28
begin
var n:=ReadInteger('n=');
var St:=new Stack <integer>;
while n>0 do begin
St.Push(n mod 10);
n:=n div 10
end;
var a:=St.ToArray;
a.Println(',');
Writeln('Сумма цифр: ',a.Sum);
Writeln('Сумма нечетных цифр: ',a.Where(x->x.IsOdd).Sum);
Writeln('Сумма старшего и младшего разрядов: ',a.First+a.Last);
end.
Пример
n= 53214212
5,3,2,1,4,2,1,2
Сумма цифр: 20
Сумма нечетных цифр: 10
Сумма старшего и младшего разрядов: 7