В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
blin42p00v7h
blin42p00v7h
04.07.2022 22:56 •  Информатика

Написать программу обработки двумерного массива: дан массив а 15 строк и 15 столбцов. заполнить массив случайными числами, найти мах, мин, и сумму элементов всего массива нужно в тетраде написать нужно написать так,как в паскале

Показать ответ
Ответ:
enikandrova04
enikandrova04
01.07.2020 23:47
var a, b, c, d, i, j :integer;
     s :array [1..100,1..100] of integer;
begin
   b:=63999;
   c:=-63999;
   for i:=1 to 15 do
      begin
      writeln;
      for j:=1 to 15 do
         begin
         s[i,j]:=random(127998)-63999;
         a:=a+s[i,j];
         if s[i,j]>c then c:=s[i,j];
         if s[i,j]<b then b:=s[i,j];
         write (s[i,j],' ');
         end;
      end;
   writeln;
   writeln ('Сумма элементов = ', a);
   writeln ('Максимальный элемент = ', c);
   writeln ('Минимальный элемент = ', b);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота