В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Boris2006
Boris2006
11.06.2022 19:51 •  Информатика

Написать программу, . напишите программу, которая находит сумму двухзначных нечетных чисел. последовательность чисел заканчивается числом 0.

Показать ответ
Ответ:
Marina11231
Marina11231
08.10.2020 00:15
// PascalABC.NET 3.3, сборка 1634 от 14.02.2018
// Внимание! Если программа не работает, обновите версию!

begin
  ReadSeqIntegerWhile(t->t<>0)
      .Where(t->t.IsOdd and t.InRange(10,99)).Sum.Println
end.
0,0(0 оценок)
Ответ:
KatyaSy
KatyaSy
08.10.2020 00:15
Program n1;
var a,sum: integer;
begin
readln(a);
sum:=0;
while a<>0 do
begin
if (a>9) and (a<100) and (a mod 2<>0) then sum:=sum+a;
readln(a);
end;
write(sum);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота