В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
turdalievab
turdalievab
22.08.2020 04:01 •  Информатика

Написать программу нахождения ymax , если задана функция: y = х2 – 100х + 10, где х изменяется от хнач. до хкон. с шагом с. программа должна так же выводить и значение х, при котором y принимает максимальное значение. значения хнач., хкон. и с должны задаваться пользователем при выполнении программы. для организации цикла воспользуйтесь оператором while.

Показать ответ
Ответ:
serjo1216
serjo1216
28.09.2020 18:54
Var 
x0,xn,c:real;
x,y,xmax,ymax:real;
begin
writeln('Xнач, Xкон:'); 
readln(x0,xn);
write('С = '); readln(c);
x:=x0;
xmax:=x; ymax:=x*x-100*x+10;
while x<xn do
 begin
 x:=x+c;
 y:=x*x-100*x+10;
 if y>ymax then begin xmax:=x; ymax:=y; end;
 end;
writeln('xmax = ',xmax,'  ymax = ',ymax);
end.

Пример:
Xнач, Xкон:
-10 20
С = 1
xmax = -10  ymax = 1110
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота