В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
richietozier6
richietozier6
01.07.2020 08:39 •  Информатика

Написать программу нахождения в одномерном массиве с [1..6] произведения и количества элементов кратных я тему не за внимание)! )

Показать ответ
Ответ:
amersjeo
amersjeo
07.10.2020 16:04
Uses Crt;

const
  n=6;
var
  i,k:byte;
  p:longint;
  a:array[1..n] of shortint;
begin
  Randomize;
  k:=0; p:=1;
  ClrScr;
  for i:=1 to n do begin
    a[i]:=Random(51)-25;  { [-25..25] }
    Write(a[i],' ');
    if a[i] mod 5=0 then begin k:=k+1; p:=p*a[i] end
    end;
  Writeln; Writeln('k=',k,', P=',p);
  ReadKey
end.

Написать программу нахождения в одномерном массиве с [1..6] произведения и количества элементов крат
Написать программу нахождения в одномерном массиве с [1..6] произведения и количества элементов крат
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота