В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
liza2002623
liza2002623
27.01.2021 17:44 •  Информатика

Написать программу нахождения суммы и произведения всех трехзначных чисел кратных 3!

Показать ответ
Ответ:
artemmenshikov2715
artemmenshikov2715
09.06.2020 16:58

program raf105;

var i,sum,pro,a:integer;

begin

writeln('Вводите 5 чисел по очереди');

pro:= 1;

 for i:=1 to 5 do

 begin

  readln(a);

  if (a>=100) and (a<=999) and ((a mod 3)=0)

    then

    begin

    sum+= a;

    pro*= a;

    end;

  end;

writeln('Сумма трёхзначных  чисел кратных трём: ',sum);

writeln('Произведение трёхзначных  чисел кратных трём: ',pro);

end.

Язык PascalABC

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота