В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
aosch2k2
aosch2k2
02.04.2023 17:07 •  Информатика

Написать программу нахождения среднего арифметического минимального и первого элементов массива r(10). найдите количество элементов в массиве е(25), абсолютная величина которых больше 8. найти сумму элементов массива а(10) удовлетворяющих условию а(х)< 10.

Показать ответ
Ответ:
petrovaanastasia26
petrovaanastasia26
18.04.2021 04:42
Великий писатель, драматург, публицист, граф лев николаевич толстой родился 9 сентября (28 августа по старому стилю) 1828 года в имении ясная поляна крапивенского уезда тульской губернии (ныне щекинского района тульской области) в одном из самых знатных дворянских семейств. он был четвертым ребенком в семье. детство будущего писателя прошло в ясной поляне. он рано осиротел, потеряв сначала мать, которая умерла, когда мальчику было два года, а затем и отца. в 1837 году семья переехала из ясной поляны в москву. опекуншей осиротевших детей стала их тетка, сестра отца александра ильинична остен-сакен. в 1841 году, после ее смерти, юный толстой с сестрой и тремя братьями переехал в казань, где жила другая тетка - пелагея ильинична юшкова, ставшая их опекуншей. подробнее - на -
0,0(0 оценок)
Ответ:
help1010100101020349
help1010100101020349
22.12.2021 06:07

program P1;
uses
crt;
var
mas : array[1..20] of integer;
i,j,k : integer;
tmp : string;
begin

clrscr;

writeln('Start array: ');

for i := 1 to 20 do
begin

mas[i] := random(100);

write(mas[i],' ');

end;


for i := 1 to 20 do
begin

if mas[i] mod 2 = 0 then
mas[i] := 0;

end;

 

for i := 1 to 20 do
begin

if mas[i] = 0 then
begin

for j := 20 downto i do
if mas[j] <> 0 then
begin

k := mas[j];
mas[j] := mas[i];
mas[i] := k;

end;

end;

end;


writeln('');
writeln('Result array: ');

for i := 1 to 20 do
write(mas[i],' ');


readln(tmp);
read(tmp);


end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота