В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
деш2
деш2
10.08.2021 04:19 •  Информатика

Написать программу нахождения площади высоты, радиусов вписанной и описанной окружности равностороннего треугольника со стороной а.​

Показать ответ
Ответ:
muzaka
muzaka
12.10.2020 02:43

# Python 3.7.2

from math import sqrt

a = int(input())

h = sqrt(3) / 2 * a

r = a / (2 * sqrt(3))

R = a / sqrt(3)

print('Высота:', h)

print('Радиус вписанной окружности:', r)

print('Радиус описанной окружности:', R)

0,0(0 оценок)
Ответ:
refddk
refddk
12.10.2020 02:43

PascalABC.Net

procedure Rad(a: real; n: integer);var  R, R2: real;begin  R := a / (2 * sin(pi / n));  R2 := R * cos(pi / n);  Println('Радиус (Описаный): ', R);  Println('Радиус (Вписаный): ', R2);end;begin  var a := ReadReal('Введите A: ');  var n := ReadInteger('Введите N: ');  Rad(a, n);end.

Varian 2

program HappyCoder; var  R, R2, A: real;  n: integer; begin  Writeln('Введите A: ');  Read(A);  Writeln('Введите N: ');  Read(n);  R := a / (2 * sin(pi / n));  R2 := R * cos(pi / n);  Writeln('Радиус (Описаный): ', R:0:3);  Writeln('Радиус (Вписаный): ', R2:0:3); end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота