В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
angelinaguseyn
angelinaguseyn
21.09.2020 05:27 •  Информатика

Написать программу нахождения наибольшего общего делителя (нод) двух натуральных чисел.а)использовать оператор repeatб) использовать оператор while

Показать ответ
Ответ:
zulu51
zulu51
27.06.2020 12:55
var a,b: integer;
function NOD(x,y: integer): integer;
begin
   if x<>0 then NOD:=NOD(y mod x,x) else NOD:=y;
end;
begin
   readln(a,b);
   writeln( 'НОД = ', NOD(a,b) );
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота