В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия

Написать программу на заполнение 2-х массивов(рост девочек и рост мальчиков).определить средний рост мальчиков.подсчитать количество девочек,у которых рост выше среднего роста мальчиков.

Показать ответ
Ответ:
annablakfare303030
annablakfare303030
24.05.2020 13:12

unit math;

var

   d,m:array[1..20] of integer;

   sr:real;

   kol,s:integer;

Begin

  for i:=1 to 20 do begin

    d[i]:=RandomRange(140,180);

    writeln('Рост ',i,'-ой девочки =',d[i],' см');

    m[i]:=RandomRange(140,190);

    writeln('Рост ',i,'-го мальчика= ',m[i],' см');

  end;

 s:=0;sr:=0;kol:=0;

 for i:=1 to 20 do s:=s+m[i];

 sr:=s/20;

 writeln('Средний рост мальчиков= ',sr,' см');

 for i:=1 to 20 do

  if d[i]>sr then kol:=kol+1;

 writeln('Колличество девочек превышающий средний рост мальчиков= ',kol);

End.

 

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота