В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Kurgan4511
Kurgan4511
01.05.2021 07:49 •  Информатика

Написать программу на языке С

Напишите функцию заполнения массива 10-ю случайными числами в диапазоне от -40 до 40, функцию вывода элементов массива.

Показать ответ
Ответ:
cheri228
cheri228
15.10.2020 12:52

//Братишка, я тебе С++ принёс

#include <iostream>

#include <ctime>

#include <cstdlib>

using namespace std;

void fill(int arr[10]){

   srand(time(NULL));

   for(int i = 0;i<10;i++){

       arr[i] = rand() % 81 + -40;

   }

}

void output(int arr[10]){

   for(int i = 0;i<10;i++){

       cout<<arr[i]<<endl;

   }

}

int main()

{

   int arr[10];

   fill(arr);

   output(arr);

   return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота