В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
саша2006101
саша2006101
15.02.2023 21:18 •  Информатика

Написать программу на языке Си, определяющую, площадь какой фигуры больше: круга радиуса R, равностороннего треугольника с длиной стороны а или квадрата со стороной d. (используя ?:).

Показать ответ
Ответ:
Swim1223
Swim1223
20.05.2022 01:33

import array

a = array.array ('i',[])

import random

_summ = _elem = 0

_len = int (input ("Lenght: "))

for l in range(_len):

   a.append(random.randrange(0,700))

   if a[l] < 50:

       _summ+=a[l]

       _elem+=1

print ("Summ: ", _summ)

if _elem != 0:

   print("Average: ", _summ/_elem)

else:

   print("Average: 0!")

print("Mass: ", a)

Результат работы:

Lenght: 20

Summ:  7

Average:  7.0

Mass:  array('i', [266, 89, 7, 407, 506, 130, 630, 362, 419, 82, 639, 619, 695, 383, 685, 477, 368, 81, 62, 199])

Lenght: 5

Summ:  18

Average:  18.0

Mass:  array('i', [486, 170, 18, 183, 307])

0,0(0 оценок)
Ответ:
marinamoshonkina
marinamoshonkina
21.05.2022 03:40

1.

string = input().split(" ")

for i in string:

   if i[-1]=="я":

       print(i)

2.

massiv=list(map(int,input().split(" ")))

maxim=max(massiv)

for i in massiv:

   if i%2==1 and i<maxim:

       maxim=i

if max(massiv)%2==0 and maxim==max(massiv):

   print("Нету нечетных элементов")

else:

   print(maxim)

3.  

massiva=[input() for i in range(10)]

massivb=[input() for i in range(10)]

massiva,massivb=massivb,massiva

print(massiva,massivb)

4.

massiva=list(map(int,input().split(" ")))

massivb=list(map(int,input().split(" ")))

massivc=list(map(int,input().split(" ")))

print("Сумма 1 массива:",sum(massiva), "Среднее арифметическое:", sum(massiva)/len(massiva))

print("Сумма 2 массива:",sum(massivb), "Среднее арифметическое:", sum(massivb)/len(massivb))

print("Сумма 3 массива:",sum(massivc), "Среднее арифметическое:", sum(massivc)/len(massivc))

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота