В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
ksenia376
ksenia376
22.08.2021 11:03 •  Информатика

Написать программу на языке с++: сформировать случайным образом целочисленную матрицу n*n. сформировать два одномерных массива а и в: в массив а записать элементы матрицы, расположенные на главной диагонали и ниже неё, в массив в - элементы, лежащие на побочной диагонали и ниже неё

Показать ответ
Ответ:
аграил9
аграил9
06.10.2020 13:15
#include <iostream>
#include <iomanip>
#include <ctime>

int main()
{
    setlocale(LC_ALL, "RUSSIAN");
    const int N = 5;
    int matrix[N][N];
    int A[(N*N) / 2], B[(N*N)/2];
    int k = 0;
    srand(time(NULL));
    for (int i = 0; i < N; i++)
    {
        std::cout << std::endl;
        for (int j = 0; j < N; j++)
        {
            matrix[i][j] = rand() % 100;
            std::cout << std::setw(3) <<  matrix[i][j] << " ";
        }
    }
    for (int i = 0; i < N; i++)
        for (int j = 0; j < N; j++)
            if (i >= j)
            {
                A[k] = matrix[i][j];
                k++;
            }
    std::cout << std::endl;
    std::cout << "Массив, содержащий элементы, лежащие на главной диагонали и ниже ее:" << std::endl;
    for (int i = 0; i < k; i++)
        std::cout << A[i] << " ";
    k = 0;
    std::cout << std::endl;
    for(int i=0; i<N; i++)
        for (int j = N - i-1; j < N; j++)
        {
            B[k] = matrix[i][j];
            k++;
        }
    std::cout << "Массив, содержащий элементы, лежащие на побочной диагонали и ниже ее:" << std::endl;
    for (int i = 0; i < k; i++)
        std::cout << B[i] << " ";
    std::cout << std::endl;
    system("pause");
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота