В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
inikulin00864
inikulin00864
29.08.2020 18:18 •  Информатика

Написать программу на языке python. создание класса автомобиль (должен обладать параметрами – скорость, количество бензина, показания температуры жидкости, одометр и : ускорения, торможения, вывода данных)

Показать ответ
Ответ:
chiminswife
chiminswife
15.08.2022 01:57
1) Площадь Тихого океана – 179 млн.кв.км. - НЕИНФОРМАТИВНО: в данный момент не нужно, будет нужно - найду сам.
2) Москва – столица России - НЕИНФОРМАТИВНО: это я и сам знаю.
3) Вчера весь день шел дождь - НЕИНФОРМАТИВНО: это я и так видел.
4) Завтра ожидается солнечная погода - ИНФОРМАТИВНО, можно спланировать, как провести день.
5) Дивергенция однородного векторного поля равна нулю - НЕИНФОРМАТИВНО, потому что ненужно.
6) Dog – собака (по-английски) НЕИНФОМАТИВНО: это я сам знаю.
7) Ro do may si, lot do may НЕИНФОРМАТИВНО: какая-то бессмыслица.
8) 2*2=4 - НЕИНФОРМАТИВНО, это вообще банальность.
0,0(0 оценок)
Ответ:
fhlurx
fhlurx
29.10.2020 02:56
1

var
n, s: integer;

begin
  Write('Введите трехзначное число: ');
  Readln(n);
  s := (n div 100) + ((n mod 100) div 10) + (n mod 10);
  if (s in [10..99]) then Writeln('Сумма цифр двухзначная (', s, ')')
  else Writeln('Сумма цифр не двухзначная (', s, ')')
end.

Тестовое решение:

Введите трехзначное число: 269
Сумма цифр двухзначная (17)

Введите трехзначное число: 125
Сумма цифр не двухзначная (8)

2

var
  n, d1, d3: integer;

begin
  Write('Введите трехзначное число: ');
  Readln(n);
  d1 := (n div 100);
  d3 := (n mod 10);
  if d1 > d3 then Writeln('Первая цифра больше третьей')
  else if d1 = d3 then Writeln('Первая цифра равна третьей')
  else Writeln('Первая цифра меньше третьей')
end.

Тестовое решение:

Введите трехзначное число: 739
Первая цифра меньше третьей
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота