В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
KeberMax
KeberMax
01.05.2020 22:38 •  Информатика

Написать программу на языке программирования Qbasic по примеру ниже(задания также ниже)


Написать программу на языке программирования Qbasic по примеру ниже(задания также ниже)
Написать программу на языке программирования Qbasic по примеру ниже(задания также ниже)

Показать ответ
Ответ:
Настя2017465
Настя2017465
01.02.2023 08:14

Объяснение:

Элемент «ИЛИ» (OR)

По другому, его зовут «дизъюнктор».

Любуемся:

Элемент ИЛИ

Опять же, название говорит само за себя.

На выходе возникает единица, когда на один ИЛИ на другой ИЛИ на оба сразу входа подана единица. Этот элемент можно назвать также элементом «И» для негативной логики: ноль на его выходе бывает только в том случае, если и на один и на второй вход поданы нули.

Едем дальше. Дальше у нас очень простенький, но очень необходимый элемент.

Элемент «НЕ» (NOT)

Чаще, его называют «инвертор».

Элемент НЕ

Надо чего-нибудь говорить по поводу его работы?

Ну тогда поехали дальше. Следующие два элемента получаются путем установки инвертора на выход элементов «И» и «ИЛИ».

Элемент «И-НЕ» (NAND)

Элемент И-НЕ

Элемент И-НЕ работает точно так же как «И», только выходной сигнал полностью противоположен. Там где у элемента «И» на выходе должен быть «0», у элемента «И-НЕ» - единица. И наоборот. Э то легко понять по эквивалентной схеме элемента:

Эквивалентная схема элемента И-НЕ

0,0(0 оценок)
Ответ:
KrystallBlack
KrystallBlack
24.05.2023 22:31

var

n,s:longint;

n1:integer;

begin

readln(n);

s:=0;

while n <> 0 do begin

n1:=n mod 10;

if n1 mod 2 = 0 then s:=s+n1;

n:=n div 10 end;

writeln('s=',s)

end.

Объяснение:

картинка

Строки 2 и 3 можно менять местами

Строки 5 и 6 можно менять местами

var

n1:integer;

n,s:longint;

begin

s:=0;

readln(n);

while n <> 0 do begin

n1:=n mod 10;

if n1 mod 2 = 0 then s:=s+n1;

n:=n div 10 end;

writeln('s=',s)

end.

Описываем переменные

Вводи число

Начальное значение переменной для накопления суммы равно 0

Цикл (пока число неравно 0):

вычисляем последнюю цифру числа

проводим проверку на чётность, если пройдена, то суммируем

отбрасываем последнюю цифру числа

Выводим результат


поместилось 9 строк а в общем 12 строк) ( это паскаль) ​
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота