В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
jesussoul
jesussoul
15.08.2021 04:53 •  Информатика

Написать программу на языке паскаль. вводятся размер и элементы одномерного массива a(n), состоящего из целых чисел. подсчитать сумму простых чисел, оканчивающихся на 3. результат вывести на экран.

Показать ответ
Ответ:
karallisa
karallisa
17.06.2020 22:33

uses crt;
Var a:array [1..100] of integer; i,n,s: integer;
Begin

Writeln('Введите размер массива'); readln(n);

For i:=1 to n do begin
                    writeln('Введите элемент массива номер  ',i); read(a[i]);
                 end;

For i:=1 to n do
    if a[i] mod 10=3 then s:=s+a[i];
    
Writeln('Сумма = ',s);

end.

 

Написано через PascalABC. Если используете другой паскаль вместо первой строчки пишите "Program 123;"

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота