Написать программу на языке паскаль. с клавиатуры вводятся несколько натуральных целых чисел. необходимо чтобы вычислялось сколько введено чисел, сколько из них четных и общая сумма этих чисел. например: вводим числа 3425 - получает количество чисел - 4, количество четных чисел - 2, сумма чисел - 14
n, m, p, k, sum, x: integer;
s: string;
c, i: byte;
begin
write('Число: ');
read(n);
m := n;
k := 0;
while m <> 0 do
begin
p := m mod 10;
K := K + 1;
m := m div 10;
end;
Str(N, s);
c := 0;
for i := 1 to Length(s) do
if s[i] in ['0', '2', '4', '6', '8'] then
Inc(c);
x := n;
sum := 0;
while (x <> 0 ) do
begin
sum := sum + (x mod 10);
x := x div 10;
end;
writeln('Количество чисел: ', k);
writeln('Количество четных чисел: ', c);
writeln('Cумма чисел : ', sum);
end.