В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
арсений201
арсений201
18.10.2021 19:28 •  Информатика

Написать программу на языке паскаль. напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. программа получает на вход количество чисел в последовательности, а затем сами числа. кто правильно напишет поставлю лучшее !

Показать ответ
Ответ:
bng453
bng453
05.10.2020 02:34
Var n,a,i,k:integer;
begin
write('n = ');
readln(n);
k:=0;
writeln('Вводите числа:');
for i:=1 to n do
 begin
 readln(a);
 if a mod 4 = 0 then k:=k+1;
 end;
writeln('k = ',k);
end.

Пример:
n = 5
Вводите числа:
15
24
73
48
94
k = 2
0,0(0 оценок)
Ответ:
эрика95
эрика95
05.10.2020 02:34
Var a: array [1..100] of integer;

chis,i: integer;

begin

readln(chis);

for i:=1 to chis do readln(a[i]);

write('Числа кратные 4:');

for i:=1 to chis do if (a[i] mod 4 = 0) then write(a[i], ' ');

end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота