В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
innahot418
innahot418
04.06.2021 21:18 •  Информатика

Написать программу на языке паскаль, напишите программу, использующую модуль, в котором описаны 2 процедуры: первая возвращает произведение двух чисел, вторая их частное.

Показать ответ
Ответ:
Покемончик12346
Покемончик12346
25.08.2020 07:21
Unit MyModule;
interface
  function prod(a,b:real):real;
  function quot(a,b:real):real;
implementation
  function prod(a,b:real):real;
  begin
    Result:=a*b
  end;
  function quot(a,b:real):real;
  begin
    Result:=a/b
  end;
end.



uses MyModule;
var
  a,b:real;
begin
  Write('Введите через пробел a и b: '); Read(a,b);
  Writeln('a*b=',prod(a,b),', a/b=',quot(a,b))
end.

Тестовое решение:
Введите через пробел a и b: 12 0.5
a*b=6, a/b=24
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота