В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
mongoliya1
mongoliya1
02.12.2021 05:29 •  Информатика

Написать программу на языке паскаль для решения . с цикла с послеусловием напишите программу, которая требует у вас пароль, например, 111. если пароль правильный, то заполняет все строки экрана сообщением «молодец». если после пятой попытки пароль все равно неверен, выходит из программы. для проверки подготовить код программы и результаты ее работы.

Показать ответ
Ответ:
Пам904
Пам904
09.06.2020 09:56
Код программы:(пароль: 105)

program raf105;

const pass = 105;

var enterpass, x:integer;

begin

repeat

 write('Введите пароль: ');

 readln(enterpass);

 if enterpass = pass

   then

     while 1=1 do

       writeln('Молодец')

   else x += 1;

until x=5;

end.

Результаты работы программы:1.

Вывод: Введите пароль:

Ввод: 105

Вывод: Молодец Молодец Молодец Молодец Молодец Молодец Молодец Молодец Молодец...

2.

Вывод: Введите пароль:

Ввод: 123

Вывод: Введите пароль:

Ввод: 106

Вывод: Введите пароль:

Ввод: 0

Вывод: Введите пароль:

Ввод: 104

Вывод: Введите пароль:

Ввод: 666

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота