Написать программу на языке pascal: : вводятся целые числа до первого числа, которое меньше двух. определить, сколько простых чисел было введено. описание переменных: q - счетчик простых чисел; n - очередное введенное число. алгоритм решения : пока введенное число больше 1, проверять его на простоту по следующему алгоритму: если число делится на любой делитель от 2 до половины от себя, то оно не простое. если число так и не разделилось ни на один из перебранных делителей, то оно простое, следовательно, увеличиваем счетчик простых чисел.
begin
readln(n);
h:=1;
while n>1 do
begin
k:=n div 2;
for i:=2 to k do
if n mod i=0 then h:=0;
q:=q+h;
h:=1;
readln(n);
end;
writeln('Простых чисел: ',q)
end.