В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
PatiFon4ik
PatiFon4ik
21.01.2023 10:56 •  Информатика

написать программу на языке Pascal❤️ В англоязычных странах объемы измеряют в галлонах я бушелях (1 галлон = 4.54 литра, 1 бушель = 8 галлонам). Вывести на экран монитора таблицу соответствия литров, галлонов и бушелей с интервалом 1 литр.
При выполнении программы на экране должен появится заголовок таблицы: «Таблица соответствия литров, галлонов и бушелей». «Литры», «Галлоны» и «Бушели» и под ними три столбца чисел: в первом слева столбце - объемы в литрах, в следующем - в галлонах и в последнем – в бушелях.​

Показать ответ
Ответ:
Pozetiv4ik24
Pozetiv4ik24
10.04.2023 10:56

не так уж и трудно, если

program project2;

var

n,a,b,c,i,k,max,min: longint;

inp,outp: text;

begin

assign(inp,'input.txt');

reset(inp);

assign(outp,'output.txt');

rewrite(outp);

readln(inp,n);

max: =0;

min: =0;

c: =0;

for i: =1 to n do

begin

read(f1,a);

if i=1 then

b: =a;

if a> max then

max: =a;

k: =a-c;

c: =a;

if k< 0 then

begin

k: =abs(k);

min: =min+k;

if k> min then

min: =k;

end;

end;

max: =max-b;

write(outp,max,' ',min);

close(inp);

close(outp);

end.

0,0(0 оценок)
Ответ:
Р000000
Р000000
12.04.2020 05:14
Приставка, предлог (не часть слова), суффикс, окончание, корень; Треугольник, отрезок, длина (не фигура), квадрат, круг; Дождь, снег, осадки (собирательное название всех остальных), иней, град; Запятая, точка, двоеточие, тире, союз (не знак препинания); Сложение, умножение, деление, слагаемое (не арифметическое действие), вычитание; Дуб, дерево (собирательное название всех остальных), ольха, тополь, ясень; Секунда, час, год, вечер (не точный промежуток времени), неделя; Горький, горячий (не относится к вкусу), кислый, соленый, сладкий; Футбол, волейбол, хоккей, плавание (не игровой вид спорта), баскетбол.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота