В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Катя2731
Катя2731
10.02.2021 00:27 •  Информатика

Написать программу на языке PASCAL, реализующую алгоритм решения следующих задач (одной на
выбор):
1. Вывод суммы натуральных чисел в заданном диапазоне
Входные данные: N1, N2 – натуральные числа (от 0 до 255), нижняя и верхняя границы
соответственно
Выходные данные: Число – сумма всех натуральных чисел от N1 до N2 включительно.
2. Вывод произведения натуральных чисел в заданном диапазоне
Входные данные: N1, N2 – натуральные числа (от 0 до 255), нижняя и верхняя границы
соответственно
Выходные данные: Число –произведение всех натуральных чисел от N1 до N2 включительно.

Показать ответ
Ответ:
bbcc2
bbcc2
03.09.2020 18:03

Задача 1

var

 i, sum, n1, n2: integer;

begin

 readln(n1, n2);

 for i := n1 to n2 do  

   sum := sum + i;

 writeln(sum);

end.

Задача 2

var

 i, n1, n2: integer;

 p: BigInteger;

begin

 p := 1;

 readln(n1, n2);

 for i := n1 to n2 do  

   p := p * i;

 writeln(p);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота