Написать программу на языке Pascal для решения задачи: а) Ввести случайным образом (возможные значения от 0 до 60) значения 7 элементов массива, содержащего целые числа. Значение каждого элемента массива уменьшить на 10. Вывести значения элементов измененного массива на экран в строчку (через пробел).
б) Ввести с клавиатуры значения 15 элементов массива, содержащего вещественные числа. Значение каждого элемента массива увеличить в 4 раза. Вывести значения элементов измененного массива на экран в столбик.
Const
s=5;
Var
ar:array[1..s] of integer;
n,m,i:integer;
begin
writeln('N');
readln(n);
writeln('M');
readln(m);
writeln('Array:');
for i:=1 to s do
readln(ar[i]);
writeln('First array:');
for i:=1 to s do
begin
write(ar[i]:4);
if ar[i] div n<>0 then ar[i]:=ar[i]+m;
end;
writeln;
writeln('Final array:');
for i:=1 to s do
write(ar[i]:4);
end.
Пример ввода:
3
3
1
2
3
4
5
Пример вывода:
First array:
1 2 3 4 5
Final array:
1 2 6 7 8
//Блок-схема во вложении
1.Скретч 3.0 (текущая версия) является улучшенной версией Скретч 2.0 и сделана на HTML5, используя движок WebGL, что даёт ему возможность работать на мобильных устройствах и планшетах. Скретч разрабатывается небольшой командой программистов для детей[3] в Массачусетском технологическом институте. Текущая версия — Скретч 3.0, выпущена в январе 2019 года. В 2008 году Скретч был портирован для микроконтроллерного модуля Arduino. Проект носит название S4A[4].
2.Создадим в Scratch такую программу. На холсте находится смайлик, пульт и
указатель. В зависимости от того, где указатель располагается на пульте, смайлик
меняет выражение своего "лица". Положение указателя пусть определяется с цвета, а не координат.
3. Представьте, что мы создаем игру, в которой герой, управляемый
пользователем, может переходить из комнаты в комнату. При этом из определенной
комнаты герой может попасть только в одну или несколько других, а не во все.
Например, пусть схема расположения комнат будет такой:
Т.е. из комнаты 1 можно попасть в комнату 2. Из второй комнаты возможен
переход в первую и третью и т.п. Событием, после которого будет производиться
переход, будет местонахождение героя у соответствующего края сцены. Так для
первой комнаты это будет правый край.
В среде программирования Scratch к фону сцены обращаются по его имени,
(если программный код составляется для объекта Сцена) или по номеру фона (для
других объектов). В нашей программе важно правильно расставить фоны по-порядку
и назвать их.
39
Теперь выберем какой-нибудь объект в качестве героя и заставим его
двигаться. Управляемое перемещение объекта может осуществляться с мыши и клавиатуры. Если выбрать мышь, то код может быть таким:
Здесь, когда пользователь нажимает мышь, то объект движется по
направлению к курсору.
Вспомним, что размер холста в Scratch равен 480х360 пикселей, а начальная
точка системы координат находится в центре. Поэтому у правого края значение x =
240, у левого x = -240. Верхний край: y = 180; нижний край: y = -180. Пусть в
дальнейшем фон меняется, когда соответствующая координата объекта равна по
модулю 200 или 150. Это связано с удобством управления.
Алгоритм перехода объекта из комнаты 1 (лаборатория) в комнату 2 (спальня)
может быть таким, как описано ниже.
Для героя:
• Когда координата x объекта становится равной 200, он посылает
соответствующее сообщение (например, "в спальню из лаборатории").
40
• Значение координаты x изменяется на противоположное, а y остается
прежним. Это создаст эффект вхождения в другую комнату.
Для сцены:
• В зависимости от того, какое сообщение получено для сцены устанавливается
соответствующий сообщению фон.
Программный код для объекта:
Программный код для сцены:
Сценарии перехода в другие комнаты аналогичны приведенным выше, за
исключением значений. Всего должно получиться восемь комбинаций перехода из
комнаты в комнату. Запрограммируйте эти переходы самостоятельно. Для воспользуйтесь таблицей ниже.
фон от сцена = ... положение от … … ... передать ... идти в … ...
1 > 200 В спальню из лаборатории x: -200
y: положение y
2 < -200 В лабораторию из спальни x: 200
y: положение y
2 > 200 В гостиную из спальни x: -200
y: положение y
3 < -200 В спальню из гостиной x: 200
y: положение y
3 > 150 В студию из гостиной x: положение x
y: -150
4 < -150 В гостиную из студии x: положение x
y: 150
3 < -150 В кабинет из гостиной x: положение x
y: 150
5 > 150 В гостиную из кабинета x: положение x y: -150
4. По идее в нашей программе смайлик должен изменять свою "улыбку" и
"выражение глаз"; т.е. он должен оставаться, с одной стороны, самим собой, а с
другой, все-таки меняться.
Для изменения объектов в Scratch используется понятие костюмов. Каждый
объект имеет хотя бы один костюм. В этом можно убедиться, если перейти на
вкладку костюмы в среднем столбце окна Scratch. Чтобы добавить новый костюм
надо нажать на кнопку Рисовать, Импорт или Камера. Однако чаще всего, придется
изменять уже готовый костюм. В этом случае копируют уже существующий костюм, а
затем редактируют его.