В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
floragormonikddd1
floragormonikddd1
21.01.2023 11:59 •  Информатика

Написать программу на языке pascal: 1. найти площадь прямоугольника, зная что длина одной стороны в два раза больше другой. 2. написать программу, которая находит и сообщает разность, произведение двух вещественных(дробных) чисел.

Показать ответ
Ответ:
lenapanfilova0
lenapanfilova0
01.05.2022 23:39

Я не буду расписывать всё по разным классам, поэтому человек в одной программе будет только один!!

package com.project;

import java.util.Scanner;

public class Name {

public static int all_marks = 0;

public static int reckoning(int mark) {

return Name.all_marks += mark;

}

public static void diplom(String name) {

if (Name.all_marks > 80) {

System.out.println("Диплом") ;

System.out.println("Награждается: " + name);

System.out.println("За набранное количество в размере: " + Name.all_marks);

}

else if ((Name.all_marks > 50) && (Name.all_marks <= 80)) {

System.out.println("Сертификат") ;

System.out.println("Награждается: " + name);

System.out.println("За набранное количество в размере: " + Name.all_marks);

}

else

System.out.println("Сертификат участника");

}

public static void main(String[] args) {

Scanner in = new Scanner(System.in);

String name;

int num_lessons, marks;

System.out.print("Enter a student's name: ");

name = in.nextLine();

System.out.print("Enter the number of items that are surrendered by a student " + name + ": ");

num_lessons = in.nextInt();

for (int i=1; i<=num_lessons; i++) {

System.out.print("Enter the number of points a student has scored for " + i + " lesson: ");

marks = in.nextInt();

reckoning(marks);

}

diplom(name);

}

}

0,0(0 оценок)
Ответ:
respons
respons
29.05.2020 14:59

Будет нарисовано что то типа заглавной буквы "Д" но только у неё правая нижняя палочка не оттуда растёт немного.

Подробнее- смотри скрин внизу (жирная линия на скрине- это так отображается рисующее перо Чертёжника, его в принципе можно увести в другое место в конце алгоритма, чтобы оно там не мешалось, только предварительно подняв перо).

Вот ваша программа (в полном нормальном виде для системы Кумир, без кучи всяких мелких ошибок типа точки вместо запятой и больших букв там где не надо):

использовать Чертежник

алг

нач

сместиться в точку (1,1)

опустить перо

сместиться в точку (1,2)

сместиться в точку (5,2)

поднять перо

сместиться в точку (5,1)

опустить перо

сместиться в точку (4,2)

сместиться в точку (4,5)

сместиться в точку (3,5)

сместиться в точку (2,4)

сместиться в точку (2,2)

кон

А вот я поправил программу, чтобы она рисовала правильную букву "Д",  и ещё после уводила перо в сторону, чтобы оно не мешало смотреть рисунок. Результат работы этой программы- смотри на втором скрине.

использовать Чертежник

алг

нач

сместиться в точку (1,1)

опустить перо

сместиться в точку (1,2)

сместиться в точку (5,2)

сместиться в точку (5,1)

поднять перо

сместиться в точку (4,2)

опустить перо

сместиться в точку (4,5)

сместиться в точку (3,5)

сместиться в точку (2,4)

сместиться в точку (2,2)

поднять перо

сместиться в точку (7,2)

кон


Что будет нарисовано после выполнения Чертежником алгоритма?Стартовая позиция Чертежника (0,0).Смест
Что будет нарисовано после выполнения Чертежником алгоритма?Стартовая позиция Чертежника (0,0).Смест
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота