В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Эля6979
Эля6979
16.02.2022 18:24 •  Информатика

Написать программу на языке C++ (c#) которая вводит целое чило n и массив из n целых чисел и определяет есть ли в массиве число 30.

Показать ответ
Ответ:
zubiks108642
zubiks108642
13.10.2020 14:49

C#

using System;

namespace ConsoleApp1

{

   class Program

   {

       static void Main(string[] args)

       {

           int n;

           bool b = false;

           Console.Write("Введите n: ");

           n = Convert.ToInt32(Console.ReadLine());

           int[] A = new int[n];

           Console.WriteLine("Введите массив: ");

           for (int i = 0; i < n; i++)

           {

               A[i] = Convert.ToInt32(Console.ReadLine());

               if (A[i] == 30) b = true;

           }

           Console.WriteLine("В массиве "+(b ? "есть" : "нет")+" числ"+ (b ? "о" : "а") + " 30");

       }

   }

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота