В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
DianaDi1111111
DianaDi1111111
12.01.2022 03:47 •  Информатика

Написать программу на яп паскаль для вычисления площади треугольника по его сторонам ab, bc, ca (формула герона). программу написать на 13 строк.

Показать ответ
Ответ:
LilClayne
LilClayne
09.10.2020 10:13

//PASCAL ABC.NET

var

 s, p, ab, bc, ca: real;

begin

 read(ab, bc, ca);

 p := (ab + bc + ca) / 2;

 s := sqrt(p * (p - ab) * (p - bc) * (p - ca));

 writeln(p, #10, s);

end.


 

0,0(0 оценок)
Ответ:
strimersakarinа
strimersakarinа
09.10.2020 10:13

Ровно 13 строк:

program Geron;

var ab,bc,ca,p: real;

begin

writeln('Определение площади треугольника по теореме Герона');

write('Введите сторону треугольника AB: ');

readln(ab);

write('Введите сторону треугольника BC: ');

readln(bc);

write('Введите сторону треугольника CA: ');

readln(ca);

p:=(ab+bc+ca)/2;

writeln('Площадь треугольника равна ',sqrt(p*(p-ab)*(p-bc)*(p-ca)):0:3)

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота