написать программу на си задача: Дана числовая последовательность чисел А1,А2,n, где n количество чисел в последовательности. Составить программу определяющую: сумму всех нечетных чисел в последовательности.
Площадь квадрата находится по формуле s=a², где a - сторона квадрата, длина диагонали квадрата d равна a√2. Периметр квадрата Р равен 4a, откуда a=P/4 Среднее арифметическое площади и диагонали (какой все же бред: соединять меры площади и длины!) может быть определено следующим образом.
var P,m:real; begin Write('Введите периметр квадрата: '); Read(P); Writeln('Среднее площади и диагонали равно ',P/8*(P/4+sqrt(2))) end.
Тестовое решение: Введите периметр квадрата: 45 Среднее площади и диагонали равно 71.2362012883487
Алгоритм1 var s : string; n1,n2 : integer; i,l : integer; begin readln (s); n1 := 0; n2 := 0; l := Length(s); for i := 1 to l do if (s[i] = ' ') then if n1 = 0 then n1 := i else n2 := i;
if n2 = 0 then s := ' ' else s := copy(s,n1+1,n2-n1-1); writeln (s); end.
Алгоритм2 var s : string; n1,n2 : integer; i,l : integer; r : boolean; begin readln (s); n1 := 0; n2 := 0; r := false; l := Length(s); i := 1; While (i<=l) and (not r) do begin if s[i] = ' ' then begin n1 := i; r := true; end; i := i +1; end;
r :=false; i := l;
While (i>0) and (not r) do begin if s[i] = ' ' then begin n2 := i; r := true; end; i := i -1; end;
if n2 = n1 then s := ' ' else s := copy(s,n1+1,n2-n1-1);
длина диагонали квадрата d равна a√2.
Периметр квадрата Р равен 4a, откуда a=P/4
Среднее арифметическое площади и диагонали (какой все же бред: соединять меры площади и длины!) может быть определено следующим образом.
var
P,m:real;
begin
Write('Введите периметр квадрата: '); Read(P);
Writeln('Среднее площади и диагонали равно ',P/8*(P/4+sqrt(2)))
end.
Тестовое решение:
Введите периметр квадрата: 45
Среднее площади и диагонали равно 71.2362012883487
Алгоритм1
var
s : string;
n1,n2 : integer;
i,l : integer;
begin
readln (s);
n1 := 0; n2 := 0;
l := Length(s);
for i := 1 to l do
if (s[i] = ' ') then
if n1 = 0 then
n1 := i
else
n2 := i;
if n2 = 0 then
s := ' '
else
s := copy(s,n1+1,n2-n1-1);
writeln (s);
end.
Алгоритм2
var
s : string;
n1,n2 : integer;
i,l : integer;
r : boolean;
begin
readln (s);
n1 := 0; n2 := 0;
r := false;
l := Length(s);
i := 1;
While (i<=l) and (not r) do
begin
if s[i] = ' ' then
begin
n1 := i;
r := true;
end;
i := i +1;
end;
r :=false;
i := l;
While (i>0) and (not r) do
begin
if s[i] = ' ' then
begin
n2 := i;
r := true;
end;
i := i -1;
end;
if n2 = n1 then
s := ' '
else
s := copy(s,n1+1,n2-n1-1);
writeln (s);
end.