В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
trofimovakarina1
trofimovakarina1
20.05.2020 17:46 •  Информатика

Написать программу на си дан текст. определить, каких букв в нем больше: строчных или прописных. если больше прописных букв, заменить все строчные буквы прописными. если больше строчных, заменить все прописные буквы строчными. если количество прописных и строчных букв равно, текст оставить без изменения.

Показать ответ
Ответ:
nastyan853958
nastyan853958
07.10.2020 02:50
На с++.
#include <string.h>#include <locale.h>#include <math.h>#include <stdio.h>#define LANG 1 //Язык: 0 - английский; 1 - русскийsize_t kA = 0, ka = 0;int delta = (LANG) ? 'а' - 'А' : 'a' - 'A';void iter(char[], void(*)(char*), void(*)(char*));void incA(char* z = 0) { kA++; }void inca(char* z = 0) { ka++; }void changeA(char* ch);void changea(char* ch);int main() { setlocale(LC_ALL, "Russian"); char str[] = "ПихАЙ СЮДА ИСХОднУЮ СТРОКУ СИмволов"; iter(str, incA, inca); iter(str, changeA, changea); printf(str); return 0;}void iter(char str[], void(*trued)(char*), void(*falsed)(char*)) { for (size_t i = 0; i < strlen(str); ++i) { if (str[i] >= 'A' && str[i] <= 'Z' || str[i] >= 'А' && str[i] <= 'Я') trued(str+i); if (str[i] >= 'a' && str[i] <= 'z' || str[i] >= 'а' && str[i] <= 'я') falsed(str + i); }}void changeA(char* ch) { if (kA < ka) { *ch = *ch + delta; }}void changea(char* ch) { if (kA > ka) { *ch = *ch - delta; }}
Написать программу на си дан текст. определить, каких букв в нем больше: строчных или прописных. есл
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота