В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
jdkdjdjjidjdjd
jdkdjdjjidjdjd
29.08.2022 14:17 •  Информатика

Написать программу на с# Зал Большого театра столь велик, что артистам при выступлении необходимо иметь радиомикрофоны.

В начале и конце спектакля все артисты находятся за кулисами. Артисты выходят на сцену и покидают сцену через правую или левую кулису, при этом артист берет с собой один микрофон. Уйдя со сцены, артист оставляет микрофон за той кулисой, через которую он ушел.

Имеется режиссерский план, в котором для каждого артиста указано его прихода и ухода со сцены, а также то, через какие кулисы он входит и выходит.

Определите, какое наименьшее число микрофонов необходимо приготовить режиссеру за каждой кулисой до начала спектакля.

Формат входных данных
Первая строка входный данных содержит натуральное число n, 1<=n<10000. Далее идет n строк – инструкции для артистов. Каждая строка состоит из двух чисел и двух букв. Первое число – время выхода артиста от начала спектакля в секундах, второе число – время ухода артиста со сцены. Потом идет одна из двух букв "l" или "r" в зависимости от того, через какую кулису (левую или правую) приходит артист и еще одна буква, указывающая через какую кулису уходит артист. Например, строка "300 500 l r" означает, что актер выходит на сцену в момент времении 300 через левую кулису и уходит со сцены в момент 500 через правую кулису.

Времена приходов и уходов – целые неотрицательные числа, не превосходящие 10000. Строки во входном файле могут идти в произвольном порядке, не обязательно упорядоченные по времени. Если в один и тот же момент один артист уходит за кулису, а другой выходит из-за этой же кулисы, то он может передать ему микрофон в этот момент.

Формат выходных данных
Программа должна вывести два числа: минимальное количество микрофонов, которое должно быть в начале спектакля за левой и за правой кулисами.

Пример
Входные данные:
3
0 100 l r
50 150 l l
100 200 r l
Выходные данные
2 0

Показать ответ
Ответ:
Marchendro77
Marchendro77
31.01.2022 08:49

Паскаль АВС:


Program kislota;
uses crt;
const n=30;
var
  e:array[1..n] of integer;
  sum,nom,i: integer;
begin
  writeln('*** alphaues is thinking... ***');
  writeln('***          OK             ***');
  writeln();
  writeln('Элементы массива:');
  randomize;
  nom:=0;
  for i:=1 to n do
    begin
      e[i]:=random(100)-50;
      write (e[i]:5);
    end;
  sum:=e[1]+e[2];
  for i:=1 to n-1 do
    if (e[i]+1 + e[i+1])>sum then
      begin
        sum:=e[i]+1 + e[i+1];
        nom:=i;
      end;
  writeln();
  writeln('Номер первого элемента пары с максимальной суммой: ',nom);
end.

0,0(0 оценок)
Ответ:
s1mple72
s1mple72
29.01.2020 18:50
uses crt; const n:Integer; var a:array[1..20] of integer; // 20 это предустановлена в условии граниа не указанно можно 99 поставить       i,j,k:integer; begin  randomize; // это для генерации случайных чмсел у тебя могут быть предусановлены  for i:=1 to n do    a[i]:=random(99); // ну собственно генерация чисел от 0 до 99( в блок схеме это не нужно)   for i:=1 to n-1 do     for j:=i+1 to n do        if a[i]>a[j] then begin  k:=a[i]; a[i]:=a[j]; a[j]:=k; end;     end. немного линни не пямые )) но разобратся сможешь
Доброе утро, , , начертить блок-схему по : задана одномерная числовая таблица из n элементов. расста
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота