В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
nikitka1011
nikitka1011
14.07.2022 21:28 •  Информатика

написать программу на С++ Ввести в 3 переменные строкового типа s1,s2,s3 ваши фамилию, имя отчество. Переставить местами значения 3-х переменных, так чтобы в s1 оказалось значение s2, в s2 - значение s3, в s3 - прежнее значение s1.

Показать ответ
Ответ:
yagodka343
yagodka343
15.02.2021 18:58

Объяснение:

#include <iostream>

#include <string>

using namespace std;

int main()

{

   string s1="Петров", s2="Иван", s3="Алексеевич", temp;

   temp = s1; //присваиваем значение s1 временной переменной temp

   s1 = s2;

   s2 = s3;

   s3 = temp;

   

   cout << s1 << s2 << s3 <<;

   return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота