В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
zavarinaira100
zavarinaira100
07.05.2023 16:45 •  Информатика

Написать программу на с++ создание модуля генератор. генератор должен циклически по истечении заданного периода времени генерировать от 1 до 3 данных. идентификаторы этих данных выбираются случайным образом из диапазона значений 0; 99. штампу времени присваевается время генерации данных. численное значение данных формируется случайным образом из диапазона -100; 0; 100; 0. код качества устанавливается в 0

Показать ответ
Ответ:
nastalut207
nastalut207
03.01.2023 04:33

запись (record) — это пользовательский тип данных, котоорый может содержать поля с различными типами данных, например:


type

 schools = (1, 2, 3, 4, 5, 6, 7, 8, 9, 10)

 students = record

    name, surname : string;

    age : byte;

    school : schools;

 end;


Для обращения к полям записи из главной программы необходимо разделять имя переменной типа Запись и поля, которое оно содержит, символом "." (точка). Например:


var

 student : students;


begin

 student.name := 'Иван';

 student.surname := 'Пупкин';

end.


Если необходимо получить или изменить значения нескольких полей записи, то удобнее использовать конструкцию with:


begin

 with student do begin

    name := 'Вася';

    surname := 'Пупкин';

    age := 12;

    school := 5;

 end;

end.

0,0(0 оценок)
Ответ:
vintrast1
vintrast1
12.12.2021 00:22

#include  

using namespace std;

int main() {

   bool repeat = true;

  while (repeat) {

       double число1, число2, число3, число4, число5;

       cout << "'Введите числа: ";

       cin >> число1 >> число2 >>число3 >> число4>>число5;

       cout << "сумма: " << число1 + число2 +число3 + число4 + число5 << endl;


       cout << "еще раз? (t/n) ";

       char;

       cin >>;

       repeat = ( == 't');

   }

   return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота