В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
хани2005
хани2005
19.11.2020 00:19 •  Информатика

Написать программу на С ++ с ПОЛНЫМ объяснением!

Задание

Задано квадратную матрицу, все элементы которой равны единице. написать

функцию void func (int ** arr, int n), которая заполняет заштрихованную область

матрицы (согласно варианту) нулями. Размер массива вводится с клавиатуры.

Показать ответ
Ответ:
slyzova1
slyzova1
20.04.2021 02:25

Відповідь:

Дивись фото

Пояснення:

<!DOCTYPE html>

<html>

<head>

  <title>Price</title>

  <meta charset="utf-8">

</head>

<body>

 <p>стоимости переговоров</p>

</body>

<script>

 {/*Написать логическое выражение для определения стоимости переговоров, если стоимость переговоров с 22 часов до 8 часов на 20% ниже, а в субботу и в воскресенье дополнительно предоставляется скидка 10%. */}

 t = +prompt('время разговоров от 0 до 24 часов')

 dt = +prompt('продолжительность разговора в минутах')

s = +prompt('стоимость минуты разговора')

 d = +prompt('день недели от 1 до 7')

 console.log('t=',t,'dt=', dt, 's=', s, 'd=', d)

 function Price (t, dt, d, s) {

  let startTalk = t*60

  let price = 0

  console.log('day = ', d)

 

  for (let i =1; i<=dt; i++){

   let night = false

   let holiday = false

   let p = s

   

   if( (startTalk+i)%1440 === 0 ){

    if (d<7){

     d=d+1

     console.log('day = ', d)

    } else {

     d=1

     console.log('day = ', d)

    }

   }

   if ( (startTalk+i)%1440>=1320 || (startTalk+i)%1440<480){

    night = true

   }

   if ( d === 6 || d===7){

    holiday = true

   }

   if (night){

    p = p - s*0.2

   

   }

   if (holiday){

    p = p-s*0.1

   }

   price = price+p

   

   console.log('стоимости '+ i+'мин. = '+ p.toFixed(2)+'$')

  }

  console.log('fin.price', price.toFixed(2), '$')

  return price.toFixed(2)

 }

 {/*Price(t, dt, d, s)*/}

 alert('стоимости переговоров  ' + '$' + Price(t, dt, d, s))

</script>

</html>


Написать решение логическое выражение в javascript. написать логическое выражение для определения ст
Написать решение логическое выражение в javascript. написать логическое выражение для определения ст
0,0(0 оценок)
Ответ:
Aann1
Aann1
28.09.2020 14:19
Вот задача для "троечников" с дополнительной оценкой:

program pr1;
uses
crt;

const
arr1 : array[1..12] of integer = (5, 4, -3, 1, 0, -4, 0, 25, -8, 0, -17, -1);

type
arr2 = array of integer;

var
arr : arr2;
n : integer;
i, sot, spl, snu : byte;
ch : char;

begin
write('Хотите использовать заданный по умолчанию массив? (y/n): ');
ch := readkey;
writeln(ch);
sot := 0;
spl := 0;
snu := 0;
if ((ch='y') or (ch='Y')) then begin
{ Используем заданный по умолчанию }
for i:=1 to 12 do begin
if arr1[i] > 0 then inc(spl);
if arr1[i] < 0 then inc(sot);
if arr1[i] = 0 then inc(snu);
write(arr1[i], ' ');
end;
writeln;
end
else begin
{ Создаём и заполняем новый массив }
write('Введите желаемый размер массива: ');
readln(n);
setLength(arr, n);
writeln('Введите элементы массива:');
for i:=0 to high(arr) do
readln(arr[i]);
for i:=0 to high(arr) do begin
if arr[i]>0 then inc(spl);
if arr[i]<0 then inc(sot);
if arr[i]=0 then inc(snu);
write(arr[i], ' ');
end;
writeln;
end;

writeln('Количество отрицательных элементов: ', sot);
writeln('Количество нулевых элементов: ', snu);
writeln('Количество положительных элементов: ', spl);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота