В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
krivisasha4
krivisasha4
18.06.2022 01:44 •  Информатика

Написать программу на С++, которая: -предлагает пользователю ввести предложение,
-считывает введенную строку,
-предлагает пользователю ввести символ,
-считывает введенный символ,
-добавляет символ пользователя после каждого пробела во введенной ранее строке
-выводит результат

Показать ответ
Ответ:
ехуотличница
ехуотличница
24.08.2020 23:47

#include <iostream>

int main() {

 std::string str;

 char n;

 std::cout << "Input your string: ";

 getline(std::cin, str);

 std::cin.clear();

 std::cout << "Input your character: ";

 std::cin >> n;

 for (int i = 0; i < str.size(); ++i) {

   if (str[i] == ' ')

     str.insert(i + 1, 1, n);

 }

 std::cout << str << "\n";

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота