В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
LetoForever
LetoForever
12.06.2020 23:34 •  Информатика

Написать программу на с++ даны три стороны одного и три стороны другого треуголь- ника. эти треугольники равновеликие, т.е. имеют равные площади.

Показать ответ
Ответ:
danilaokolot
danilaokolot
03.10.2020 07:22
#include <iostream>
#include <cmath>
using namespace std;
double eps = 0.000001;
double sq(double a, double b, double c)
{
   double p = (a + b + c) / 2;
   return sqrt(p * (p - a) * (p - b) * (p - c));
}
int main() 
{
   double a1, b1, c1, a2, b2, c2;
   cin >> a1 >> b1 >> c1 >> a2 >> b2 >> c2;
   if (sq(a1, b1, c1) >= sq(a2, b2, c2) - eps && sq(a1, b1, c1) <= sq(a2, b2, c2) + eps)
      cout << "YES";
   else
      cout << "NO";
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота