Войти
Регистрация
Спроси ai-bota
В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Показать больше
Показать меньше
leraklybnika
15.03.2023 19:58 •
Информатика
Написать программу на С++ Дано натуральное число n. Получить все меньшие n натуральные
числа, квадрат суммы цифр которых равен некоторому заданному
числу m.
Показать ответ
Ответ:
Hehehe225
10.05.2023 06:52
Uses Graphabc;
begin
SetWindowWidth(800);
SetWindowHeight(900);
SetPenWidth(1);
PutPixel(400, 400, clred);
Line(0, 150, 100, 150);
Line(0, 150, 100, 200);
Line(100, 150, 150, 100);
Line(100, 50, 200, 150);
Line(100, 50, 200, 0);
Line(200, 0, 250, 50);
Line(250, 50, 300, 0);
Line(300, 0, 300, 100);
Line(300, 100, 350, 100);
Line(350, 100, 250, 150);
Line(250, 150, 300, 350);
Line(300, 350, 400, 400);
Line(50, 300, 100, 200);
Line(50, 300, 100, 250);
Line(100, 250, 150, 550);
Line(150, 550, 300, 650);
Line(400, 400, 500, 250);
Line(500, 250, 650, 250);
Line(650, 250, 750, 450);
Line(750, 450, 650, 400);
Line(650, 400, 550, 500);
Line(550, 500, 650, 450);
Line(750, 600, 650, 450);
Line(600, 550, 750, 600);
Line(700, 700, 600, 550);
Line(500, 600, 700, 700);
Line(400, 650, 500, 600);
Line(400, 800, 400, 650);
Line(450, 850, 400, 800);
Line(250, 850, 450, 850);
Line(350, 800, 250, 850);
Line(300, 650, 350, 800);
end.
0,0
(0 оценок)
Ответ:
Caflen
27.06.2021 23:45
Обозначим количество кроликов r, количество кур - c.
Тогда 2c+4r=128; c+2r=64 → c=64-2r, r=0,1,2,...32
// PascalABC.NET 3.2, сборка 1431 от 28.04.2017
// Внимание! Если программа не работает, обновите версию!
begin
var s:=Range(0,32).Select(r->(r,64-2*r));
Write('(Кролики-куры):'); s.Println
end.
Результат:
(Кролики-куры):(0,64) (1,62) (2,60) (3,58) (4,56) (5,54) (6,52) (7,50) (8,48) (9,46) (10,44) (11,42) (12,40) (13,38) (14,36) (15,34) (16,32) (17,30) (18,28) (19,26) (20,24) (21,22) (22,20) (23,18) (24,16) (25,14) (26,12) (27,10) (28,8) (29,6) (30,4) (31,2) (32,0)
0,0
(0 оценок)
Популярные вопросы: Информатика
буслай
21.05.2022 03:47
Найдите количество натуральных чисел, меньших 10000, которые не делятся ни на 7, ни на 11, ни на13, ни на 17(то есть, при делении ни на одно из этих чисел остаток не...
OakCadet
29.10.2022 02:36
Допустимые значения для величины «название месяца года» — год змеи понедельник ноябрь автомобиль...
fayafaya1
18.12.2021 15:49
с системой счисления ((...
ychenik555555555
17.07.2020 22:31
Известно, что в таблице компьютерных кодов ASCII каждой букве (символу) соответствует двоичный код. Декодируйте слово: 10011000 10001000 10010100 10010000. * Подпись...
Dasha9716
17.07.2020 22:31
A. Петины Финансы Ограничение времени:1 секунда Ограничение памяти:64Mb Ввод:finance.in Вывод:finance.out Петя решил организовать учет своих денежных трат в течение двух...
nata121114
07.05.2020 07:08
Решите это информатика ...
Асамия
13.11.2021 13:06
1024 байтов, 2 в 10 степени байтов,2 в 13 степени байтов, 2 в 16 степени байтов, 2 в 13 степени битов, 2 в 16 степени битов переведите в килобайт...
малая555
13.11.2021 13:06
Решить с цикла с предусловием 1)организовать проверку пароля, если пароль верный – написать «вход в систему разрешен», если пароль не угадан 5 раз - прекратить проверку...
Яна775975
13.06.2020 19:10
Какому числу соответствует развернутая запись приведенного числа? 2*103 + 1*102 + 7*101 + 9*100 + 4*10-1...
solomijahladij6
22.09.2021 08:40
Страны-лидеры по экспорту чая в мире...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
begin
SetWindowWidth(800);
SetWindowHeight(900);
SetPenWidth(1);
PutPixel(400, 400, clred);
Line(0, 150, 100, 150);
Line(0, 150, 100, 200);
Line(100, 150, 150, 100);
Line(100, 50, 200, 150);
Line(100, 50, 200, 0);
Line(200, 0, 250, 50);
Line(250, 50, 300, 0);
Line(300, 0, 300, 100);
Line(300, 100, 350, 100);
Line(350, 100, 250, 150);
Line(250, 150, 300, 350);
Line(300, 350, 400, 400);
Line(50, 300, 100, 200);
Line(50, 300, 100, 250);
Line(100, 250, 150, 550);
Line(150, 550, 300, 650);
Line(400, 400, 500, 250);
Line(500, 250, 650, 250);
Line(650, 250, 750, 450);
Line(750, 450, 650, 400);
Line(650, 400, 550, 500);
Line(550, 500, 650, 450);
Line(750, 600, 650, 450);
Line(600, 550, 750, 600);
Line(700, 700, 600, 550);
Line(500, 600, 700, 700);
Line(400, 650, 500, 600);
Line(400, 800, 400, 650);
Line(450, 850, 400, 800);
Line(250, 850, 450, 850);
Line(350, 800, 250, 850);
Line(300, 650, 350, 800);
end.
Тогда 2c+4r=128; c+2r=64 → c=64-2r, r=0,1,2,...32
// PascalABC.NET 3.2, сборка 1431 от 28.04.2017
// Внимание! Если программа не работает, обновите версию!
begin
var s:=Range(0,32).Select(r->(r,64-2*r));
Write('(Кролики-куры):'); s.Println
end.
Результат:
(Кролики-куры):(0,64) (1,62) (2,60) (3,58) (4,56) (5,54) (6,52) (7,50) (8,48) (9,46) (10,44) (11,42) (12,40) (13,38) (14,36) (15,34) (16,32) (17,30) (18,28) (19,26) (20,24) (21,22) (22,20) (23,18) (24,16) (25,14) (26,12) (27,10) (28,8) (29,6) (30,4) (31,2) (32,0)