В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
gushagusha
gushagusha
28.06.2021 03:18 •  Информатика

написать программу на python Создай базу интересов. Сначала у первого пользователя запрашиваем число интересов, которое он хочет ввести, затем он вводит их и они добавляются в первое множество. Ту же самую операцию проводим для второго пользователя.
Результат работы программы. Программа выводит на экран множество, в котором записаны совпавшие интересы. Если совпадений нет, программа выводит строку ‘Нет общих интересов’.


написать программу на python Создай базу интересов. Сначала у первого пользователя запрашиваем число

Показать ответ
Ответ:
1Айжан11
1Айжан11
28.01.2021 15:00

interests1 = [input(f"Введите {i+1} интерес: ") for i in range(int(input("Введите кол-во интересов: ")))]

interests2 = [input(f"Введите {i+1} интерес: ") for i in range(int(input("2Введите кол-во интересов: ")))]

general = []

for i in interests1:

   for ii in interests2:

       if i == ii:

           general.append(i)

if len(general) != 0:

   print(f" {len(general)} общих интереса:  {general}")

else:

   print("Нет общих интересов")


написать программу на python Создай базу интересов. Сначала у первого пользователя запрашиваем число
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота