В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
cvetok555
cvetok555
21.03.2021 12:23 •  Информатика

Написать программу на питоне которая выводит сколько в корзине (гриб,гриба,грибов)


Написать программу на питоне которая выводит сколько в корзине (гриб,гриба,грибов)

Показать ответ
Ответ:
плвлаовг
плвлаовг
22.01.2022 20:40

Решение 1:

nominative = 1  # окончания им.падеж: гриб

generative = [2, 3, 4]  # список окончаний род.падеж: гриба

plural_generative = [5, 6, 7, 8, 9, 0]  # список окончаний род.падеж множ-го: грибов

for number in range(0, 51):  # цикл с значением от 0 до 51

   """number % 10  возвращает последнюю цифру из числа"""

   if (number % 10) == nominative:  

       print(f"{number} гриб")

   elif (number % 10) in generative:

       print(f"{number} гриба")

   elif (number % 10) in plural_generative:

       print(f"{number} грибов")

Решение 2:

nominative = 1  # окончания им.падеж: гриб

generative = [2, 3, 4]  # список окончаний род.падеж: гриба

for number in range(0, 51):  # цикл с значением от 0 до 51

   """number % 10  возвращает последнию цифру из числа"""

   if (number % 10) == nominative:

       print(f"{number} гриб")

   elif (number % 10) in generative:

       print(f"{number} гриба")

   else:

       print(f"{number} грибов")

Объяснение:

В комментариях.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота