Написать программу на питоне 3, которая выводит таблицу значений функции у=|x-2|+|x+l|. Диапазон изменения аргумента от -4 до 4, шаг приращения аргумента 0,5.
1 скорее всего верно. Об этом точно написано как минимум в документации к Python. Так как это интерпретируемый язык, 5 скорее всего верно, но есть библиотеки, использующие C/С++ для вычислений, поэтому в некоторых случаях вычисления проводятся почти так же быстро, как в C++.
Гипотетически, можно создать процессор, под который можно было бы легко скомпилировать программу на Python. Язык программирования — абстракция, вещь в себе, поэтому он может быть как интерпретируемый, так и компилируемый, но в данном случае не существует истинных компиляторов (не в байт-код) Python, поэтому 1 верно, а 2 нет.
3 и 4 верны, так как на Android и iOS существуют интерпретаторы Python (Pythonista 3 для iOS и Pydroid для Android, например).
1 скорее всего верно. Об этом точно написано как минимум в документации к Python. Так как это интерпретируемый язык, 5 скорее всего верно, но есть библиотеки, использующие C/С++ для вычислений, поэтому в некоторых случаях вычисления проводятся почти так же быстро, как в C++.
Гипотетически, можно создать процессор, под который можно было бы легко скомпилировать программу на Python. Язык программирования — абстракция, вещь в себе, поэтому он может быть как интерпретируемый, так и компилируемый, но в данном случае не существует истинных компиляторов (не в байт-код) Python, поэтому 1 верно, а 2 нет.
3 и 4 верны, так как на Android и iOS существуют интерпретаторы Python (Pythonista 3 для iOS и Pydroid для Android, например).
//Поскольку вы не указали структуру файла и язык программирования, то подберу их сам.
//ЯП: C#
//Структура: рост/имя/вес/страна проживания
Код:
using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.IO;
namespace Prog
{
class Program
{
static void Main(string[] args)
{
string location = "C://Test//Persons.txt";
try
{
int size = File.ReadLines(location).Count();
if (size > 0)
{
List<string> person = new List<string>();
string[] tallestPerson = new string[4];
int maxHeight = -1;
int height = 0;
int index = 0;
StreamReader PersonsReader = new StreamReader(location, Encoding.Default);
for (int i = 0; i < size; i++)
{
person.Add(PersonsReader.ReadLine());
height = Convert.ToInt32(person[i].Remove(person[i].IndexOf("/")));
if (height > maxHeight)
{
maxHeight = height;
index = i;
}
}
string tmp = person[index];
int paramIndex = 0;
for (int j = 0; j < tmp.Length; j++)
{
if (tmp[j] != '/')
tallestPerson[paramIndex] += tmp[j];
else
paramIndex++;
}
Console.WriteLine("Самый высокий человек: " + tallestPerson[1]);
Console.WriteLine("Рост: " + tallestPerson[0] + " см");
Console.WriteLine("Вес: " + tallestPerson[2] + " кг");
Console.WriteLine("Страна проживания: " + tallestPerson[3]);
}
else
{
Console.WriteLine("Файл пустой!");
}
}
catch (Exception)
{
Console.WriteLine("Ошибка! Файл не нейден, либо нарушена его структура!");
}
finally
{
Console.ReadKey();
}
}
}
}