написать программу на паскале: Задать символьные файлы F1 и F2. Пеpеписать с сохpанением поpядка следования компоненты файла F1 в файл F2, а компоненты файла F2 - в файл F1, использовать вс файл F3.
1) Ақпаратты бағдарламаға түрлендіру тапсырмасын орындайтын және барлық есептеу процестерін басқаруды жүзеге асыратын компьютердің орталық бөлігі.
2) Мақсатына сәйкес процессор регистрлері ерекшеленеді: аккумулятор - арифметикалық және логикалық операциялардың аралық нәтижелерін және енгізу-шығару нұсқауларын сақтау үшін қолданылады; ... контроллерлер - процессордың күйін басқаратын ақпараттарды, сонымен қатар жүйелік кестелердің адрестерін сақтайды.
Var ar:array[1..n] of integer; ar2:array[1..n] of integer; i,k:integer;
function prost(a:integer):boolean; var i:integer; b:boolean; begin b:=true; for i:=2 to a div 2 do if a mod i=0 then begin; b:=false; break; end; if a=1 then b:=false; prost:=b; end;
begin; randomize; k:=0; for i:=1 to n do begin; ar[i]:=random(101); write(ar[i]:4); end; writeln; for i:=1 to n do if prost(ar[i]) then begin; inc(k); ar2[k]:=ar[i]; write(ar2[k]:4); end; end.
1) Ақпаратты бағдарламаға түрлендіру тапсырмасын орындайтын және барлық есептеу процестерін басқаруды жүзеге асыратын компьютердің орталық бөлігі.
2) Мақсатына сәйкес процессор регистрлері ерекшеленеді: аккумулятор - арифметикалық және логикалық операциялардың аралық нәтижелерін және енгізу-шығару нұсқауларын сақтау үшін қолданылады; ... контроллерлер - процессордың күйін басқаратын ақпараттарды, сонымен қатар жүйелік кестелердің адрестерін сақтайды.
3) Процессордың негізгі сипаттамалары:
• тактілік жиілік;
• разрядтылық;
• жұмыс кернеуі;
• кэш-жады өлшемі.
n=5;
Var
ar:array[1..n] of integer;
ar2:array[1..n] of integer;
i,k:integer;
function prost(a:integer):boolean;
var i:integer;
b:boolean;
begin
b:=true;
for i:=2 to a div 2 do
if a mod i=0 then
begin;
b:=false;
break;
end;
if a=1 then b:=false;
prost:=b;
end;
begin;
randomize;
k:=0;
for i:=1 to n do
begin;
ar[i]:=random(101);
write(ar[i]:4);
end;
writeln;
for i:=1 to n do
if prost(ar[i]) then
begin;
inc(k);
ar2[k]:=ar[i];
write(ar2[k]:4);
end;
end.