В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
irakeksik
irakeksik
20.08.2021 17:37 •  Информатика

Написать программу на паскале : пользователь вводит зарплату в рублях,например 20000,вычесть из этой зарплаты 13 %,результат вывести на экран

Показать ответ
Ответ:
feterina
feterina
02.10.2020 11:35
Это задача на вычисление суммы после уплаты налога.
Если s0  - исходная сумма, а р - процент налога, то ищется s=s0-s0*p/100.
Окончательная формула: s=s0(1-p/100)

const
  p=13;  { налог в процентах }
var
  s0,s:real;
begin
  Write('Введите сумму '); Read(s0);
  s:=s0*(1-p/100);
  { а теперь округлим сумму до копеек, т.е. до 0.01 }
  s:=Int(100*(s+0.005))/100;
  Writeln('Сумма после вычета налога ',p,'% составит ',s:0:2)
end.

Тестовое решение:
Введите сумму 2000
Сумма после вычета налога 13% составит 1740.00

Замечание. При целочисленной зарплате и целочисленном проценте налога оператор s:=Int(100*(s+0.005))/100; не нужен, поскольку в дробной части всегда будет не больше двух знаков. Но, поскольку о сумме зарплаты ничего не говорится, а дано только конкретное значение, которое понято как тестовый пример, было предложено решение с округлением.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота