В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
nastyamamontova
nastyamamontova
28.05.2023 15:14 •  Информатика

Написать программу на паскале по : сформировать двумерный массив b размером 4 x 4 (4 – количество строк; 4 – количество столбцов) с генератора случайных чисел и вывести элементы массива на экран и в файл. вычислить и вывести на экран и в файл строку матрицы b, содержащую максимальное количество отрицательных элементов (оформить вычисление количества отрицательных элементов в виде функции).
сделал пока что первую часть, не знаю как дальше:
var ar: array[1..4, 1..4] of integer;
i, j: byte;
f: text;
begin
assign(f,'mas.txt');
rewrite(f);
randomize;
for i: =1 to 4 do
begin
for j: =1 to 4 do
begin
ar[i, j]: = random (200) - 100;
write (inttostr(ar[i, j])+' ');
write (f, inttostr(ar[i, j])+' ');
end;
writeln (f, ''); writeln ();
end;
close (f);
end.

Показать ответ
Ответ:
dashamaer2
dashamaer2
10.10.2020 10:09

program ArrayCalc;

var

 ar: array[1..4, 1..4] of integer;

function Neg (Row: Integer): Integer;

var

 i: Integer;

begin

 Result := 0;

 for i := 1 to 4 do

   if ar [Row, i] <= 0 then

     inc (Result);

end;

var

 i, j, imax, n, nmax: byte;

 f: text;

begin

 assign(f, 'mas.txt');

 rewrite (f);

 randomize;

 for i := 1 to 4 do begin

   for j := 1 to 4 do begin

     ar[i, j] := random (200) - 100;

     write (IntToStr (ar [i, j]) :4);

     write (f, IntToStr (ar [i, j]) :4);

   end;

   writeln (f, '');

   writeln;

 end;

 close (f);

 imax := 1;

 nmax := 0;

 for i := 1 to 4 do begin

   n := Neg (i);

   if n > nmax then begin

     nmax := n;

     imax := i

   end;

 end;

 WriteLn;

 WriteLn ('Строка массива:');

 for j := 1 to 4 do

   Write (ar [imax, j] :4);

 ReadLn;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота