В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Vostafi
Vostafi
19.10.2020 23:33 •  Информатика

Написать программу на паскале. напишите программу, которая в последовательности целых чисел вычисляет сумму всех чисел, которые кратны 6 или 11. программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность). количество чисел не превышает 1000. введённые числа по модулю не превышают 30 000. программа должна вывести одно число: сумму всех чисел, которые кратны 6 или 11.

Показать ответ
Ответ:
Dimka3113
Dimka3113
25.06.2020 17:23
Uses crt;
var a,sum:integer;
begin
     sum:=0;
     repeat
           read(a);
           if (a mod 6=0) or (a mod 11=0) then sum:=sum+a;
     until a=0;
     writeln(sum);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота