В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
viktoria383
viktoria383
05.10.2021 17:35 •  Информатика

Написать программу на паскале на электронную почту вам пришло письмо, подписанное аббревиатурой (первыми буквами фамилии, имени и отчества(далее - фио) отправителя) аббревиатура оказалась вам не знакома. у вас есть список всех предполагаемых отправителей,взятые из ранее полученных писем, среди
которых различных людей с такой аббревиатурой не больше 10. вам предлагается написать эффективную, в том числе по используемой памяти , программу, которая определит всех вероятных адресатов - людей , фио которых можно сократить до нужной аббревиатуры. фио следует выдать в порядке убывания частоты из
встречаемости в списке. на вход программе в первой строке подается аббревиатура - строка, состоящая из 3 заглавных латинских букв. во второй строке находится число n - количество фио, полученных в результате анализа почты, не все из них подходят под указанную аббревиатуру. значение n может быть
велико. в каждой из следующих n строк записано 3 слова: имя фамилия отчество соответствующего человека. слова разделяются одним пробелом. в конце и в начале строки пробелов нет. все слова записаны заглавными латинскими буквами. длинна фио не превышает 100 символов. гарантируется, что хотя бы один
человек с нужной аббревиатурой есть. пример входных данных: ipi 4 ivanov petr ivanovich petrov ivan ivanovich ivanov petr ivanovich ilyin petr ilyich программа должна вывести предполагаемых отправителей письма с указанием частоты их встречаемости в списке (в порядке убывания частоты). пример
выходных данных для выше примера: ivanov petr ivanovich 2 ilyin petr ilyich 1

Показать ответ
Ответ:
Ульяна2732
Ульяна2732
25.04.2023 20:44

1. Это двухмерный массив

(TypeError: unsupported operand type(s) for +=: 'int' and 'list')

2. 3x4 ([3][4])

3. Сложение элементов двумерного массива.

Только вот работать не будет, я полагаю здесь должны были складываться все элементы массивов, но на фото он прибавляет к переменной S не числа а массивы. И это выдаёт ошибку, так что...

Я бы сделал это так:

b = [[3, 5, 7, 78], [12, 10, 9, 56], [45, 31, 14, 23]]

s = 0

for i in b:

   for j in i:

       s += j

# Или используя len:

for i in range(len(b)):

   for j in range(len(i)):

       s += b[i][j]

print('s =', s)

# s = 293

0,0(0 оценок)
Ответ:
polibfbxbdbdbcb
polibfbxbdbdbcb
23.09.2020 16:35

Код:

from random import choice

YourScore = 0

ComputerScore = 0

MOVES = "камень", "ножницы", "бумага"

while ((YourScore != 3) and (ComputerScore != 3)):

   print(f"Текущий счет - Игрок: {YourScore} - Компьютер: {ComputerScore}")

   while True:

       YourMove = input(

           "Ваш ход, введите камень/ножницы/бумага ").strip().lower()

       if YourMove in MOVES:

           break

   ComputerMove = choice(MOVES)

   print(f"\nВаш ход: {YourMove}\nХод компьютера: {ComputerMove}\n")

   if YourMove == ComputerMove:

       print("У вас ничья!")

       # Не выйгрывает никто

   elif (YourMove == MOVES[0] and ComputerMove == MOVES[1]):  # Камень VS Ножницы

       print("Вы победили компьютер!")

       YourScore += 1

   elif (YourMove == MOVES[1] and ComputerMove == MOVES[2]):  # Ножницы VS Бумага

       print("Вы победили компьютер!")

       YourScore += 1

   elif (YourMove == MOVES[2] and ComputerMove == MOVES[0]):  # Бумага VS Камень

       print("Вы победили компьютер!")

       YourScore += 1

   else:

       print("Компьютер вас победил!")

       ComputerScore += 1

   print()

Могу ещё дать ссылку на PasteBIN

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота